GoodTech SMTP Server < 5.17 Multiple Buffer Overflows

Critical Nessus Plugin ID 19384


The remote SMTP server contains several buffer overflow flaws.


The version of GoodTech SMTP Server running on the remote host is prone to multiple buffer overflow vulnerabilities when processing RCPT TO commands. An attacker can exploit these flaws to run arbitrary code remotely, by default as the SYSTEM user.


Upgrade to GoodTech SMTP Server 5.17 or later.

See Also

Plugin Details

Severity: Critical

ID: 19384

File Name: goodtech_smtpd_517.nasl

Version: $Revision: 1.13 $

Type: remote

Published: 2005/08/04

Modified: 2011/03/11

Dependencies: 10263

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

Vulnerability Information

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2005/07/23

Reference Information

CVE: CVE-2005-2387

BID: 14357

OSVDB: 18250