CBL Mariner 2.0 Security Update: opa / node-problem-detector (CVE-2024-24786)

medium Nessus Plugin ID 193710

Synopsis

The remote CBL Mariner host is missing one or more security updates.

Description

The version of opa / node-problem-detector installed on the remote CBL Mariner 2.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2024-24786 advisory.

- The protojson.Unmarshal function can enter an infinite loop when unmarshaling certain forms of invalid JSON. This condition can occur when unmarshaling into a message which contains a google.protobuf.Any value, or when the UnmarshalOptions.DiscardUnknown option is set. (CVE-2024-24786)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://nvd.nist.gov/vuln/detail/CVE-2024-24786

Plugin Details

Severity: Medium

ID: 193710

File Name: mariner_CVE-2024-24786.nasl

Version: 1.0

Type: local

Published: 4/23/2024

Updated: 4/23/2024

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2024-24786

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:microsoft:cbl-mariner:node-problem-detector, p-cpe:/a:microsoft:cbl-mariner:node-problem-detector-config, p-cpe:/a:microsoft:cbl-mariner:node-problem-detector-debuginfo, p-cpe:/a:microsoft:cbl-mariner:opa, p-cpe:/a:microsoft:cbl-mariner:opa-debuginfo, x-cpe:/o:microsoft:cbl-mariner

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/CBLMariner/release, Host/CBLMariner/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 4/9/2024

Vulnerability Publication Date: 3/5/2024

Reference Information

CVE: CVE-2024-24786