GLSA-200507-29 : pstotext: Remote execution of arbitrary code

High Nessus Plugin ID 19360


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200507-29 (pstotext: Remote execution of arbitrary code)

Max Vozeler reported that pstotext calls the GhostScript interpreter on untrusted PostScript files without specifying the -dSAFER option.
Impact :

An attacker could craft a malicious PostScript file and entice a user to run pstotext on it, resulting in the execution of arbitrary commands with the permissions of the user running pstotext.
Workaround :

There is no known workaround at this time.


All pstotext users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-text/pstotext-1.8g-r1'

See Also

Plugin Details

Severity: High

ID: 19360

File Name: gentoo_GLSA-200507-29.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/08/01

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:pstotext, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/07/31

Vulnerability Publication Date: 2005/07/24

Reference Information

CVE: CVE-2005-2536

OSVDB: 18251

GLSA: 200507-29