GLSA-200507-25 : Clam AntiVirus: Integer overflows

High Nessus Plugin ID 19327


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200507-25 (Clam AntiVirus: Integer overflows)

Neel Mehta and Alex Wheeler discovered that Clam AntiVirus is vulnerable to integer overflows when handling the TNEF, CHM and FSG file formats.
Impact :

By sending a specially crafted file an attacker could execute arbitrary code with the permissions of the user running Clam AntiVirus.
Workaround :

There is no known workaround at this time.


All Clam AntiVirus users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-antivirus/clamav-0.86.2'

See Also

Plugin Details

Severity: High

ID: 19327

File Name: gentoo_GLSA-200507-25.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/07/31

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:clamav, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/07/26

Vulnerability Publication Date: 2005/07/24

Reference Information

CVE: CVE-2005-2450

OSVDB: 18257, 18258, 18259

GLSA: 200507-25