Palo Alto Networks PAN-OS 10.2.x < 10.2.9-h1 / 11.0.x < 11.0.4-h1 / 11.1.x < 11.1.2-h3 Vulnerability

critical Nessus Plugin ID 193255

Synopsis

The remote PAN-OS host is affected by a vulnerability

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 10.2.x prior to 10.2.9-h1 or 11.0.x prior to 11.0.4-h1 or 11.1.x prior to 11.1.2-h3. It is, therefore, affected by a vulnerability.

- A command injection as a result of arbitrary file creation vulnerability in the GlobalProtect feature of Palo Alto Networks PAN-OS software for specific PAN-OS versions and distinct feature configurations may enable an unauthenticated attacker to execute arbitrary code with root privileges on the firewall.
(CVE-2024-3400)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PAN-OS 10.2.9-h1 / 11.0.4-h1 / 11.1.2-h3 or later

See Also

https://security.paloaltonetworks.com/CVE-2024-3400

https://unit42.paloaltonetworks.com/cve-2024-3400/

https://www.paloaltonetworks.com/blog/2024/04/more-on-the-pan-os-cve/

http://www.nessus.org/u?9a9a8f24

Plugin Details

Severity: Critical

ID: 193255

File Name: palo_alto_CVE-2024-3400.nasl

Version: 1.9

Type: combined

Published: 4/12/2024

Updated: 5/30/2024

Configuration: Enable paranoid mode

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Critical

Score: 10.0

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2024-3400

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 9.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/12/2024

Vulnerability Publication Date: 4/12/2024

CISA Known Exploited Vulnerability Due Dates: 4/19/2024

Exploitable With

Core Impact

Metasploit (Palo Alto Networks PAN-OS Unauthenticated Remote Code Execution)

Reference Information

CVE: CVE-2024-3400

CWE: 20, 77

IAVA: 2024-A-0230