PHP 8.3.x < 8.3.6 Multiple Vulnerabilities

medium Nessus Plugin ID 193201

Synopsis

The version PHP running on the remote web server is affected by multiple vulnerabilities.

Description

The version of PHP installed on the remote host is prior to 8.3.6. It is, therefore, affected by multiple vulnerabilities as referenced in the Version 8.3.6 advisory.

- In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the vulnerability enables network and same-site attackers to set a standard insecure cookie in the victim's browser which is treated as a `__Host-` or `__Secure-` cookie by PHP applications. (CVE-2022-31629)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 8.3.6 or later.

See Also

http://php.net/ChangeLog-8.php#8.3.6

Plugin Details

Severity: Medium

ID: 193201

File Name: php_8_3_6.nasl

Version: 1.1

Type: remote

Family: CGI abuses

Published: 4/11/2024

Updated: 4/19/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.3

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS Score Source: CVE-2022-31629

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/11/2024

Vulnerability Publication Date: 9/28/2022

Reference Information

CVE: CVE-2022-31629, CVE-2024-1874, CVE-2024-2756, CVE-2024-2757, CVE-2024-3096

IAVA: 2024-A-0244