Opera < 8.02 Multiple Vulnerabilities

High Nessus Plugin ID 19312


The remote host contains a web browser which is affected by multiple issues.


The remote host is using Opera, an alternative web browser.

The version of Opera installed on the remote host contains several flaws. One involves imaging dragging and could result in cross-site scripting attacks and user file retrieval. A second may let attackers spoof the file extension in the file download dialog provided the 'Arial Unicode MS' font has been installed, which is the case with various Microsoft Office products. And a third is a design error in the processing of mouse clicks in new browser windows that may be exploited to trick a user into downloading and executing arbitrary programs on the affected host.


Upgrade to Opera 8.02 or later.

See Also




Plugin Details

Severity: High

ID: 19312

File Name: opera_802.nasl

Version: $Revision: 1.19 $

Type: local

Agent: windows

Family: Windows

Published: 2005/07/29

Modified: 2016/12/07

Dependencies: 21746

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version_UI

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2005/07/28

Reference Information

CVE: CVE-2005-2405, CVE-2005-2406, CVE-2005-2407

BID: 14402, 14410, 15835

OSVDB: 18468, 18469, 19129, 21765