Adobe Bridge 13.x < 13.0.7 / 14.x < 14.0.3 Vulnerability (APSB24-24)

medium Nessus Plugin ID 193108

Synopsis

Adobe Bridge installed on remote Windows host is affected by a vulnerability

Description

The version of Adobe Bridge installed on the remote Windows host is prior to 13.0.7 or 14.0.3. It is, therefore, affected by a vulnerability as referenced in the apsb24-24 advisory.

- Bridge versions 13.0.6, 14.0.2 and earlier are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file. (CVE-2024-20771)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Bridge version 13.0.7 or 14.0.3 or later.

See Also

https://helpx.adobe.com/security/products/bridge/apsb24-24.html

Plugin Details

Severity: Medium

ID: 193108

File Name: adobe_bridge_apsb24-24.nasl

Version: 1.2

Type: local

Agent: windows

Family: Windows

Published: 4/9/2024

Updated: 4/24/2024

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2024-20771

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:bridge

Required KB Items: SMB/Registry/Enumerated, installed_sw/Adobe Bridge

Exploit Ease: No known exploits are available

Patch Publication Date: 4/9/2024

Vulnerability Publication Date: 4/9/2024

Reference Information

CVE: CVE-2024-20771

CWE: 125

IAVA: 2024-A-0214