Airport < 4.2

Medium Nessus Plugin ID 19295


The remote host is missing a Mac OS X update that fixes a security issue.


The remote host is running a version of Mac OS X which contains an Airport driver with an automatic network association vulnerability, that may cause a computer to connect to potentially malicious networks without notifying the end-user.


Upgrade to Airport 4.2 or later.

See Also

Plugin Details

Severity: Medium

ID: 19295

File Name: macosx_Airport_42.nasl

Version: 1.17

Type: local

Agent: macosx

Published: 2005/07/25

Modified: 2017/05/30

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:U/RC:C

Vulnerability Information

Required KB Items: Host/MacOSX/packages

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2005/07/19

Vulnerability Publication Date: 2005/07/15

Reference Information

CVE: CVE-2005-2196

BID: 14321

OSVDB: 18085