Fedora Core 4 : kdenetwork-3.4.1-0.fc4.2 (2005-624)

High Nessus Plugin ID 19292


The remote Fedora Core host is missing a security update.


Multiple integer overflow flaws were found in the way Kopete processes Gadu-Gadu messages. A remote attacker could send a specially crafted Gadu-Gadu message which would cause Kopete to crash or possibly execute arbitrary code. The Common Vulnerabilities and Exposures project assigned the name CVE-2005-1852 to this issue.

Users of Kopete should update to these packages which contain a patch to correct this issue.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected kdenetwork, kdenetwork-debuginfo and / or kdenetwork-devel packages.

See Also


Plugin Details

Severity: High

ID: 19292

File Name: fedora_2005-624.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2005/07/24

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:kdenetwork, p-cpe:/a:fedoraproject:fedora:kdenetwork-debuginfo, p-cpe:/a:fedoraproject:fedora:kdenetwork-devel, cpe:/o:fedoraproject:fedora_core:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2005/07/22

Reference Information

CVE: CVE-2005-1852

FEDORA: 2005-624