Elasticsearch 8.4.0 < 8.11.1 DoS (ESA-2024-05)

medium Nessus Plugin ID 192892


The instance of Elasticsearch installed on the remote host is affected by a denial of service vulnerability.


The version of Elasticsearch installed on the remote host is between 8.4.0 and prior to 8.11.1. It is, therefore, affected by a denial of service (DoS) vulnerability, due to an uncaught exception that occurs when an encrypted PDF is passed to an attachment processor through the REST API. The Elasticsearch ingest node that attempts to parse the PDF file will crash. This does not happen with password-protected PDF files or with unencrypted PDF files.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade Elasticsearch to 8.11.1 or later.

See Also


Plugin Details

Severity: Medium

ID: 192892

File Name: elasticsearch_esa_2024_05.nasl

Version: 1.4

Type: combined

Agent: unix

Family: Misc.

Published: 4/3/2024

Updated: 6/14/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Low

Score: 1.4


Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

CVSS Score Source: CVE-2024-23449


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:elastic:elasticsearch, cpe:/a:elasticsearch:elasticsearch

Required KB Items: installed_sw/Elasticsearch

Exploit Ease: No known exploits are available

Patch Publication Date: 11/13/2023

Vulnerability Publication Date: 3/29/2024

Reference Information

CVE: CVE-2024-23449

IAVA: 2024-A-0191-S