GLSA-200507-18 : MediaWiki: XSS vulnerability

Medium Nessus Plugin ID 19231


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200507-18 (MediaWiki: XSS vulnerability)

MediaWiki fails to escape a parameter in the page move template correctly.
Impact :

By enticing a user to visit a specially crafted URL, a remote attacker could exploit this vulnerability to inject malicious JavaScript code that will be executed in a user's browser session in the context of the vulnerable site.
Workaround :

There is no known workaround at this time.


All MediaWiki users should upgrade to the latest available version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.4.7'

See Also

Plugin Details

Severity: Medium

ID: 19231

File Name: gentoo_GLSA-200507-18.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/07/20

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mediawiki, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/07/20

Vulnerability Publication Date: 2005/07/07

Reference Information

CVE: CVE-2005-2396

OSVDB: 17763

GLSA: 200507-18