Jenkins LTS < 2.440.2 / Jenkins weekly < 2.444

high Nessus Plugin ID 192307


An application running on a remote web server host is affected by a vulnerability


According to its its self-reported version number, the version of Jenkins running on the remote web server is Jenkins LTS prior to 2.440.2 or Jenkins weekly prior to 2.444. It is, therefore, affected by a vulnerability:

- Jetty is a Java based web server and servlet engine. An HTTP/2 SSL connection that is established and TCP congested will be leaked when it times out. An attacker can cause many connections to end up in this state, and the server may run out of file descriptors, eventually causing the server to stop accepting new connections from valid clients. The vulnerability is patched in 9.4.54, 10.0.20, 11.0.20, and 12.0.6.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade Jenkins weekly to version 2.444 or later, or Jenkins LTS to version 2.440.2 or later.

See Also

Plugin Details

Severity: High

ID: 192307

File Name: jenkins_2_444.nasl

Version: 1.0

Type: combined

Agent: windows, macosx, unix

Family: CGI abuses

Published: 3/20/2024

Updated: 3/20/2024

Configuration: Enable thorough checks

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2024-22201


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:jenkins:jenkins, cpe:/a:cloudbees:jenkins

Required KB Items: installed_sw/Jenkins

Exploit Ease: No known exploits are available

Patch Publication Date: 3/20/2024

Vulnerability Publication Date: 2/26/2024

Reference Information

CVE: CVE-2024-22201