RHEL 3 : cups (RHSA-2005:571)

High Nessus Plugin ID 19213


The remote Red Hat host is missing one or more security updates.


Updated CUPS packages that fix a security issue are now available for Red Hat Enterprise Linux 3.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

The Common UNIX Printing System (CUPS) provides a portable printing layer for UNIX(R) operating systems.

When processing a request, the CUPS scheduler would use case-sensitive matching on the queue name to decide which authorization policy should be used. However, queue names are not case-sensitive. An unauthorized user could print to a password-protected queue without needing a password. The Common Vulnerabilities and Exposures project has assigned the name CVE-2005-2154 to this issue.

Please note that the version of CUPS included in Red Hat Enterprise Linux 4 is not vulnerable to this issue.

All users of CUPS should upgrade to these erratum packages which contain a backported patch to correct this issue.


Update the affected cups, cups-devel and / or cups-libs packages.

See Also



Plugin Details

Severity: High

ID: 19213

File Name: redhat-RHSA-2005-571.nasl

Version: $Revision: 1.19 $

Type: local

Agent: unix

Published: 2005/07/16

Modified: 2016/12/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:cups, p-cpe:/a:redhat:enterprise_linux:cups-devel, p-cpe:/a:redhat:enterprise_linux:cups-libs, cpe:/o:redhat:enterprise_linux:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2005/07/14

Vulnerability Publication Date: 2004/05/13

Reference Information

CVE: CVE-2004-2154

OSVDB: 17912

RHSA: 2005:571