Mattermost Server 5.34.x < 7.1.9 / 7.2.x < 7.8.4 / 7.9.x < 7.9.3 / 7.10.0 (MMSA-2023-00159)

medium Nessus Plugin ID 192027


The remote host is missing a security update.


The version of Mattermost Server installed on the remote host is prior to 7.1.9, 7.8.4, or 7.9.3 / 7.10.0. It is, therefore, affected by a vulnerability as referenced in the MMSA-2023-00159 advisory.

- Mattermost fails to normalize UTF confusable characters when determining if a preview should be generated for a hyperlink, allowing an attacker to trigger link preview on a disallowed domain using a specially crafted link. (CVE-2023-2808)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Mattermost Server version 7.1.9 / 7.8.4 / 7.9.3 / 7.10.0 or later.

See Also

Plugin Details

Severity: Medium

ID: 192027

File Name: mattermost_server_MMSA-2023-00159.nasl

Version: 1.0

Type: remote

Family: CGI abuses

Published: 3/13/2024

Updated: 3/13/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 1.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2023-2808


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mattermost:mattermost_server

Required KB Items: installed_sw/Mattermost Server

Exploit Ease: No known exploits are available

Patch Publication Date: 4/27/2023

Vulnerability Publication Date: 5/29/2023

Reference Information

CVE: CVE-2023-2808