GitLab 11.3 < 16.7.7 / 16.8 < 16.8.4 / 16.9 < 16.9.2 (CVE-2024-0199)

high Nessus Plugin ID 191649


The version of GitLab installed on the remote host is affected by a vulnerability.


The version of GitLab installed on the remote host is affected by a vulnerability, as follows:

- An authorization bypass vulnerability was discovered in GitLab affecting versions 11.3 prior to 16.7.7, 16.7.6 prior to 16.8.4, and 16.8.3 prior to 16.9.2. An attacker could bypass CODEOWNERS by utilizing a crafted payload in an old feature branch to perform malicious actions. (CVE-2024-0199)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 16.7.7, 16.8.4, 16.9.2 or later.

See Also

Plugin Details

Severity: High

ID: 191649

File Name: gitlab_cve-2024-0199.nasl

Version: 1.3

Type: combined

Agent: unix

Family: CGI abuses

Published: 3/6/2024

Updated: 5/3/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: High

Score: 7.1


Risk Factor: Medium

Base Score: 6.6

Temporal Score: 4.9

Vector: CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:N

CVSS Score Source: CVE-2024-0199


Risk Factor: High

Base Score: 7.7

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 3/6/2024

Vulnerability Publication Date: 3/6/2024

Reference Information

CVE: CVE-2024-0199

IAVA: 2024-A-0140-S