CentOS 9 : tomcat-9.0.62-14.el9

medium Nessus Plugin ID 191428

Synopsis

The remote CentOS host is missing one or more security updates for tomcat.

Description

The remote CentOS Linux 9 host has a package installed that is affected by multiple vulnerabilities as referenced in the tomcat-9.0.62-14.el9 build changelog.

- not including the secure attribute causes information (CVE-2023-28708)

- The fix for CVE-2023-24998 was incomplete for Apache Tomcat 11.0.0-M2 to 11.0.0-M4, 10.1.5 to 10.1.7, 9.0.71 to 9.0.73 and 8.5.85 to 8.5.87. If non-default HTTP connector settings were used such that the maxParameterCount could be reached using query string parameters and a request was submitted that supplied exactly maxParameterCount parameters in the query string, the limit for uploaded request parts could be bypassed with the potential for a denial of service to occur. (CVE-2023-28709)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the CentOS 9 Stream tomcat package.

See Also

https://kojihub.stream.centos.org/koji/buildinfo?buildID=35629

Plugin Details

Severity: Medium

ID: 191428

File Name: centos9_tomcat-9_0_62-14.nasl

Version: 1.0

Type: local

Agent: unix

Published: 2/29/2024

Updated: 2/29/2024

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2023-28708

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:centos:centos:9, p-cpe:/a:centos:centos:tomcat

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 8/1/2023

Vulnerability Publication Date: 2/23/2023

Reference Information

CVE: CVE-2023-28708, CVE-2023-28709

IAVA: 2023-A-0156-S, 2023-A-0266-S