CentOS 9 : vim-8.2.2637-16.el9

high Nessus Plugin ID 191421

Synopsis

The remote CentOS host is missing one or more security updates for vim.

Description

The remote CentOS Linux 9 host has a package installed that is affected by multiple vulnerabilities as referenced in the vim-8.2.2637-16.el9 build changelog.

- Use of Out-of-range Pointer Offset in vim prior (CVE-2022-0554)

- Heap-based Buffer Overflow occurs in vim (CVE-2022-0943)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the CentOS 9 Stream vim package.

See Also

https://kojihub.stream.centos.org/koji/buildinfo?buildID=17818

Plugin Details

Severity: High

ID: 191421

File Name: centos9_vim-8_2_2637-16.nasl

Version: 1.0

Type: local

Agent: unix

Published: 2/29/2024

Updated: 2/29/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2022-0554

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

CVSS Score Source: CVE-2022-0943

Vulnerability Information

CPE: cpe:/a:centos:centos:9, p-cpe:/a:centos:centos:vim

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/28/2022

Vulnerability Publication Date: 2/10/2022

Reference Information

CVE: CVE-2022-0554, CVE-2022-0943