CentOS 9 : microcode_ctl-20220809-1.el9

medium Nessus Plugin ID 191417

Synopsis

The remote CentOS host is missing one or more security updates for microcode_ctl.

Description

The remote CentOS Linux 9 host has a package installed that is affected by multiple vulnerabilities as referenced in the microcode_ctl-20220809-1.el9 build changelog.

- Insufficient control flow management in some Intel(R) Processors may allow an authenticated user to potentially enable a denial of service via local access. (CVE-2021-0127)

- Improper initialization of shared resources in some Intel(R) Processors may allow an authenticated user to potentially enable information disclosure via local access. (CVE-2021-0145)

- Out of bounds read under complex microarchitectural condition in memory subsystem for some Intel Atom(R) Processors may allow authenticated user to potentially enable information disclosure or cause denial of service via network access. (CVE-2021-33120)

- Sensitive information accessible by physical probing of JTAG interface for some Intel(R) Processors with SGX may allow an unprivileged user to potentially enable information disclosure via physical access.
(CVE-2022-0005)

- Improper access control for some Intel(R) Xeon(R) Processors may allow an authenticated user to potentially enable information disclosure via local access. (CVE-2022-21131)

- Improper input validation for some Intel(R) Xeon(R) Processors may allow a privileged user to potentially enable denial of service via local access. (CVE-2022-21136)

- Processor optimization removal or modification of security-critical code for some Intel(R) Processors may allow an authenticated user to potentially enable information disclosure via local access.
(CVE-2022-21151)

- Improper isolation of shared resources in some Intel(R) Processors may allow a privileged user to potentially enable information disclosure via local access. (CVE-2022-21233)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the CentOS 9 Stream microcode_ctl package.

See Also

https://kojihub.stream.centos.org/koji/buildinfo?buildID=25051

Plugin Details

Severity: Medium

ID: 191417

File Name: centos9_microcode_ctl-20220809-1.nasl

Version: 1.0

Type: local

Agent: unix

Published: 2/29/2024

Updated: 2/29/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:P

CVSS Score Source: CVE-2021-33120

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS Score Source: CVE-2022-21233

Vulnerability Information

CPE: cpe:/a:centos:centos:9, p-cpe:/a:centos:centos:microcode_ctl

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 9/20/2022

Vulnerability Publication Date: 2/9/2022

Reference Information

CVE: CVE-2021-0127, CVE-2021-0145, CVE-2021-33120, CVE-2022-0005, CVE-2022-21131, CVE-2022-21136, CVE-2022-21151, CVE-2022-21233