GitLab 15.1 < 16.7.6 / 16.8 < 16.8.3 / 16.9 < 16.9.1 (CVE-2024-0410)

high Nessus Plugin ID 190867

Synopsis

The version of GitLab installed on the remote host is affected by a vulnerability.

Description

The version of GitLab installed on the remote host is affected by a vulnerability, as follows:

- An authorization bypass vulnerability was discovered in GitLab affecting versions 15.1 prior to 16.7.6, 16.8 prior to 16.8.3, and 16.9 prior to 16.9.1. A developer could bypass CODEOWNERS approvals by creating a merge conflict. (CVE-2024-0410)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 16.7.6, 16.8.3, 16.9.1 or later.

See Also

http://www.nessus.org/u?9ef605f4

Plugin Details

Severity: High

ID: 190867

File Name: gitlab_cve-2024-0410.nasl

Version: 1.4

Type: combined

Agent: unix

Family: CGI abuses

Published: 2/21/2024

Updated: 3/8/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: High

Score: 7.1

CVSS v2

Risk Factor: Medium

Base Score: 6.6

Temporal Score: 4.9

Vector: CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:N

CVSS Score Source: CVE-2024-0410

CVSS v3

Risk Factor: High

Base Score: 7.7

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 2/21/2024

Vulnerability Publication Date: 2/21/2024

Reference Information

CVE: CVE-2024-0410

IAVA: 2024-A-0113-S