Palo Alto Networks PAN-OS 9.0.x < 9.0.17-h4 / 9.1.x < 9.1.17 / 10.1.x < 10.1.12 Vulnerability

medium Nessus Plugin ID 190586


The remote PAN-OS host is affected by a vulnerability


The version of Palo Alto Networks PAN-OS running on the remote host is 9.0.x prior to 9.0.17-h4 or 9.1.x prior to 9.1.17 or 10.1.x prior to 10.1.12. It is, therefore, affected by a vulnerability.

- A reflected cross-site scripting (XSS) vulnerability in the GlobalProtect portal feature of Palo Alto Networks PAN-OS software enables execution of malicious JavaScript in the context of a user's browser if that user clicks on a malicious link, allowing phishing attacks that could lead to credential theft.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to PAN-OS 9.0.17-h4 / 9.1.17 / 10.1.12 or later

See Also

Plugin Details

Severity: Medium

ID: 190586

File Name: palo_alto_CVE-2024-0010.nasl

Version: 1.0

Type: combined

Published: 2/15/2024

Updated: 2/15/2024

Configuration: Enable paranoid mode

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 1.4


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2024-0010


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/14/2024

Vulnerability Publication Date: 2/14/2024

Reference Information

CVE: CVE-2024-0010

CWE: 79