Drupal < 9.5.11 / 10.0 DoS

high Nessus Plugin ID 189231


A PHP application running on the remote web server is affected by a denial of service vulnerability.


According to its self-reported version, the instance of Drupal running on the remote web server is potentially vulnerable to a denial of service vulnerability due to improper handling of structural elements. This vulnerability has been reported against 9.x versions of Drupal. The Drupal maintainers have concluded that the latest 9.5.x release and Drupal 10.x are unaffected by this vulnerability.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Drupal 9.5.11, 10 or later.

See Also


Plugin Details

Severity: High

ID: 189231

File Name: drupal_CVE-2024-22362.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 1/19/2024

Updated: 1/24/2024

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2024-22362


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 1/16/2024

Vulnerability Publication Date: 1/16/2024

Reference Information

CVE: CVE-2024-22362

IAVA: 2024-A-0039