Atlassian Confluence < 8.5.4 RCE (CONFSERVER-93833)

critical Nessus Plugin ID 188068


The remote Atlassian Confluence host is missing a security update.


The version of Atlassian Confluence Server running on the remote host is affected by a vulnerability as referenced in the CONFSERVER-93833 advisory.

- RCE (Remote Code Execution) in Confluence Data Center and Server due to a template injection vulnerability. An unauthenticated, remote attacker, can exploit this vulnerability to run arbitrary code on the affected instance. (CVE-2023-22527)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Atlassian Confluence version 8.5.4, 8.6.0, 8.7.1 or later.

See Also

Plugin Details

Severity: Critical

ID: 188068

File Name: confluence_confserver-93833.nasl

Version: 1.8

Type: combined

Agent: windows, macosx, unix

Family: CGI abuses

Published: 1/16/2024

Updated: 2/23/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Critical

Score: 9.6


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-22527


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: installed_sw/Atlassian Confluence

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/4/2024

Vulnerability Publication Date: 1/16/2024

CISA Known Exploited Vulnerability Due Dates: 2/14/2024

Exploitable With

Core Impact

Metasploit (Atlassian Confluence SSTI Injection)

Reference Information

CVE: CVE-2023-22527

IAVA: 2024-A-0025-S