Atlassian Confluence 7.13 < 7.19.17 / 8.0.x < 8.4.5 / 8.5.x < 8.5.4 / 8.6.x < 8.6.2 DoS (CONFSERVER-93623)

high Nessus Plugin ID 188065


The remote Atlassian Confluence host is missing a security update.


The version of Atlassian Confluence Server running on the remote host is 7.13.x prior to 7.19.17, 8.0.x prior to 8.5.4, or 8.6.x prior to 8.6.2. It is, therefore, affected by a denial of service (DoS) vulnerability as referenced in the CONFSERVER-93623 advisory. The vulnerability lies in the com.squareup.okio:okio-jvm dependency of Confluence Server, which is known to be vulnerable to DoS when using the GzipSource class to handle a crafted GZIP archive. This is due to GzipSource not handling an exception that might be raised when parsing a malformed gzip buffer.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Atlassian Confluence version 7.19.17, 8.5.4, 8.6.2 or later.

See Also

Plugin Details

Severity: High

ID: 188065

File Name: confluence_confserver-93623.nasl

Version: 1.1

Type: combined

Agent: windows, macosx, unix

Family: CGI abuses

Published: 1/16/2024

Updated: 1/17/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: High

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-3635


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: installed_sw/Atlassian Confluence

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/16/2024

Vulnerability Publication Date: 1/10/2024

Reference Information

CVE: CVE-2023-3635