Atlassian Confluence < 7.19.17 / 7.20.x < 8.3.4 / 8.4.x < 8.4.5 / 8.5.x < 8.5.4 / 8.6.x < 8.6.2 / 8.7.x < 8.7.1 (CONFSERVER-93361)

high Nessus Plugin ID 187978


The remote Atlassian Confluence host is missing a security update.


The version of Atlassian Confluence Server running on the remote host is affected by a vulnerability as referenced in the CONFSERVER-93361 advisory.

- A vulnerability was discovered in the indexOf function of JSONParserByteArray in JSON Smart versions 1.3 and 2.4 which causes a denial of service (DOS) via a crafted web request. (CVE-2021-31684)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Atlassian Confluence version 7.19.17, 8.3.4, 8.4.5, 8.5.4, 8.6.2, 8.7.1 or later.

See Also

Plugin Details

Severity: High

ID: 187978

File Name: confluence_confserver-93361.nasl

Version: 1.0

Type: combined

Agent: windows, macosx, unix

Family: CGI abuses

Published: 1/12/2024

Updated: 1/12/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2021-31684


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: installed_sw/Atlassian Confluence

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/27/2023

Vulnerability Publication Date: 6/1/2021

Reference Information

CVE: CVE-2021-31684