GitLab 8.13 < 16.5.6 / 16.6 < 16.6.4 / 16.7 < 16.7.2 (CVE-2023-5356)

high Nessus Plugin ID 187957

Synopsis

The version of GitLab installed on the remote host is affected by a vulnerability.

Description

The version of GitLab installed on the remote host is affected by a vulnerability, as follows:

- Incorrect authorization checks in GitLab CE/EE from all versions starting from 8.13 before 16.5.6, all versions starting from 16.6 before 16.6.4, all versions starting from 16.7 before 16.7.2, allows a user to abuse slack/mattermost integrations to execute slash commands as another user. (CVE-2023-5356)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 16.5.6, 16.6.4, 16.7.2 or later.

See Also

http://www.nessus.org/u?8e54b268

https://gitlab.com/gitlab-org/gitlab/-/issues/427154

https://hackerone.com/reports/2188868

Plugin Details

Severity: High

ID: 187957

File Name: gitlab_cve-2023-5356.nasl

Version: 1.7

Type: combined

Agent: unix

Family: CGI abuses

Published: 1/11/2024

Updated: 5/17/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2023-5356

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 1/11/2024

Vulnerability Publication Date: 1/11/2024

Reference Information

CVE: CVE-2023-5356

IAVA: 2024-A-0041-S