Ubuntu 18.04 ESM : GnuTLS vulnerability (USN-6499-2)

medium Nessus Plugin ID 187680

Synopsis

The remote Ubuntu host is missing a security update.

Description

The remote Ubuntu 18.04 ESM host has packages installed that are affected by a vulnerability as referenced in the USN-6499-2 advisory.

- A vulnerability was found that the response times to malformed ciphertexts in RSA-PSK ClientKeyExchange differ from response times of ciphertexts with correct PKCS#1 v1.5 padding. (CVE-2023-5981)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-6499-2

Plugin Details

Severity: Medium

ID: 187680

File Name: ubuntu_USN-6499-2.nasl

Version: 1.0

Type: local

Agent: unix

Published: 1/8/2024

Updated: 1/8/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2023-5981

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:esm, p-cpe:/a:canonical:ubuntu_linux:gnutls-bin, p-cpe:/a:canonical:ubuntu_linux:libgnutls-dane0, p-cpe:/a:canonical:ubuntu_linux:libgnutls-openssl27, p-cpe:/a:canonical:ubuntu_linux:libgnutls28-dev, p-cpe:/a:canonical:ubuntu_linux:libgnutls30, p-cpe:/a:canonical:ubuntu_linux:libgnutlsxx28

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/8/2024

Vulnerability Publication Date: 11/28/2023

Reference Information

CVE: CVE-2023-5981

USN: 6499-2