Oracle Linux 8 : tigervnc (ELSA-2024-0018)

high Nessus Plugin ID 187638

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2024-0018 advisory.

- A flaw was found in xorg-server. Querying or changing XKB button actions such as moving from a touchpad to a mouse can result in out-of-bounds memory reads and writes. This may allow local privilege escalation or possible remote code execution in cases where X11 forwarding is involved. (CVE-2023-6377)

- A flaw was found in xorg-server. A specially crafted request to RRChangeProviderProperty or RRChangeOutputProperty can trigger an integer overflow which may lead to a disclosure of sensitive information. (CVE-2023-6478)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://linux.oracle.com/errata/ELSA-2024-0018.html

Plugin Details

Severity: High

ID: 187638

File Name: oraclelinux_ELSA-2024-0018.nasl

Version: 1.0

Type: local

Agent: unix

Published: 1/4/2024

Updated: 1/4/2024

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2023-6478

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS Score Source: CVE-2023-6377

Vulnerability Information

CPE: cpe:/a:oracle:linux:8::appstream, cpe:/o:oracle:linux:8, p-cpe:/a:oracle:linux:tigervnc, p-cpe:/a:oracle:linux:tigervnc-icons, p-cpe:/a:oracle:linux:tigervnc-license, p-cpe:/a:oracle:linux:tigervnc-selinux, p-cpe:/a:oracle:linux:tigervnc-server, p-cpe:/a:oracle:linux:tigervnc-server-minimal, p-cpe:/a:oracle:linux:tigervnc-server-module

Required KB Items: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 1/4/2024

Vulnerability Publication Date: 12/13/2023

Reference Information

CVE: CVE-2023-6377, CVE-2023-6478