Debian DSA-5578-1 : ghostscript - security update

high Nessus Plugin ID 187033


The remote Debian host is missing a security-related update.


The remote Debian 12 host has packages installed that are affected by a vulnerability as referenced in the dsa-5578 advisory.

- An issue was discovered in the function gdev_prn_open_printer_seekable() in Artifex Ghostscript through 10.02.0 allows remote attackers to crash the application via a dangling pointer. (CVE-2023-46751)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the ghostscript packages.

For the stable distribution (bookworm), this problem has been fixed in version 10.0.0~dfsg-11+deb12u3.

See Also

Plugin Details

Severity: High

ID: 187033

File Name: debian_DSA-5578.nasl

Version: 1.0

Type: local

Agent: unix

Published: 12/15/2023

Updated: 12/15/2023

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-46751


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ghostscript-doc, p-cpe:/a:debian:debian_linux:libgs9-common, p-cpe:/a:debian:debian_linux:ghostscript-x, p-cpe:/a:debian:debian_linux:libgs10, p-cpe:/a:debian:debian_linux:libgs10-common, p-cpe:/a:debian:debian_linux:ghostscript, p-cpe:/a:debian:debian_linux:libgs-dev, p-cpe:/a:debian:debian_linux:libgs-common, cpe:/o:debian:debian_linux:12.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 12/15/2023

Vulnerability Publication Date: 12/6/2023

Reference Information

CVE: CVE-2023-46751

IAVB: 2023-B-0097