Firefox < 1.0.6 Multiple Vulnerabilities

high Nessus Plugin ID 18689
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.6

Synopsis

The remote Windows host contains a web browser that is affected by multiple vulnerabilities.

Description

The remote version of Firefox contains various security issues that may allow an attacker execute arbitrary code on the remote host.

Solution

Upgrade to Firefox 1.0.6 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2005-45/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-46/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-47/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-48/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-49/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-50/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-51/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-52/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-53/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-54/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-55/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-56/

Plugin Details

Severity: High

ID: 18689

File Name: mozilla_firefox_105.nasl

Version: 1.30

Type: local

Agent: windows

Family: Windows

Published: 7/13/2005

Updated: 7/17/2018

Dependencies: mozilla_org_installed.nasl

Risk Information

Risk Factor: High

VPR Score: 6.6

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:*

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 7/19/2005

Vulnerability Publication Date: 4/11/2005

Exploitable With

Metasploit (Mozilla Suite/Firefox compareTo() Code Execution)

Reference Information

CVE: CVE-2004-0718, CVE-2005-1937, CVE-2005-2260, CVE-2005-2261, CVE-2005-2263, CVE-2005-2265, CVE-2005-2266, CVE-2005-2267, CVE-2005-2268, CVE-2005-2269, CVE-2005-2270, CVE-2005-2262, CVE-2005-2264, CVE-2005-2395

BID: 14325, 14242