GLSA-200507-09 : Adobe Acrobat Reader: Buffer overflow vulnerability

Medium Nessus Plugin ID 18668


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200507-09 (Adobe Acrobat Reader: Buffer overflow vulnerability)

A buffer overflow has been discovered in the UnixAppOpenFilePerform() function, which is called when Adobe Acrobat Reader tries to open a file with the '\\Filespec' tag.
Impact :

By enticing a user to open a specially crafted PDF document, a remote attacker could exploit this vulnerability to execute arbitrary code.
Workaround :

There is no known workaround at this time.


Since Adobe will most likely not update the 5.0 series of Adobe Acrobat Reader for Linux, all users should upgrade to the latest available version of the 7.0 series:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-text/acroread-7.0'

See Also

Plugin Details

Severity: Medium

ID: 18668

File Name: gentoo_GLSA-200507-09.nasl

Version: $Revision: 1.18 $

Type: local

Published: 2005/07/11

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:acroread, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/07/11

Vulnerability Publication Date: 2005/07/05

Reference Information

CVE: CVE-2005-1625

OSVDB: 17740

GLSA: 200507-09