Apache Struts 2.5.0 < 2.5.33 / 6.0.0 < Remote Code Execution (S2-066)

critical Nessus Plugin ID 186643


Apache Struts installed on the remote host is affected by Remote Code Execution vulnerability


The version of Apache Struts installed on the remote host is prior to 2.5.33 or It is, therefore, affected by a vulnerability as referenced in the S2-066 advisory.

- An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.5.33 or or later. Alternatively, apply the workaround as referenced in in the vendor's security bulletin

See Also


Plugin Details

Severity: Critical

ID: 186643

File Name: struts_S2-066.nasl

Version: 1.5

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 12/7/2023

Updated: 2/15/2024

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information


Risk Factor: Critical

Score: 9.4


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-50164


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/5/2023

Vulnerability Publication Date: 12/3/2023

Exploitable With

Core Impact

Reference Information

CVE: CVE-2023-50164

IAVA: 2023-A-0675