SolarWinds Serv-U 15.4 < 15.4.1

medium Nessus Plugin ID 186585

Synopsis

SolarWinds Serv-U is affected by a vulnerability

Description

The version of SolarWinds Serv-U installed on the remote host is prior to 15.4.1. It is, therefore, affected by a vulnerability as referenced in the serv-u_15_4_1 advisory.

- A vulnerability has been identified within Serv-U 15.4 that allows an authenticated actor to insert content on the file share function feature of Serv-U, which could be used maliciously. (CVE-2023-40053)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Serv-U version 15.4.1 or later.

See Also

http://www.nessus.org/u?e030944e

Plugin Details

Severity: Medium

ID: 186585

File Name: solarwinds_serv-u_15_4_1.nasl

Version: 1.2

Type: remote

Agent: windows, macosx, unix

Family: FTP

Published: 12/5/2023

Updated: 12/12/2023

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 1.6

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

CVSS Score Source: CVE-2023-40053

CVSS v3

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:solarwinds:serv-u, cpe:/a:solarwinds:serv-u_file_server, cpe:/a:serv-u:serv-u

Required KB Items: installed_sw/Serv-U

Exploit Ease: No known exploits are available

Patch Publication Date: 12/5/2023

Vulnerability Publication Date: 12/5/2023

Reference Information

CVE: CVE-2023-40053

IAVA: 2023-A-0671