Apache Superset < 2.1.0 Secure Session Key

critical Nessus Plugin ID 186510


An application installed on the remote host is missing a vendor-supplied update.


The version of Apache Superset installed on the remote host is affected a potential unsecure session key vulnerability. Installations that have not altered the default configured SECRET_KEY according to the installation instructions, or that use a predictable key phrase, would allow for an unauthenticated attacker to access the user dashboard with full administrator rights, allowing the attacker to compromise the system.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Superset version 2.1.0 or later.

See Also




Plugin Details

Severity: Critical

ID: 186510

File Name: apache_superset_CVE-2023-27524.nasl

Version: 1.6

Type: local

Family: Misc.

Published: 12/1/2023

Updated: 1/8/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: Critical

Score: 9.2


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-27524


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:superset

Required KB Items: installed_sw/Apache Superset

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/4/2023

Vulnerability Publication Date: 4/24/2023

CISA Known Exploited Vulnerability Due Dates: 1/29/2024

Exploitable With

Metasploit (Apache Superset Signed Cookie RCE)

Reference Information

CVE: CVE-2023-27524