Apple iOS < 17.1.2 Multiple Vulnerabilities (HT214031)

high Nessus Plugin ID 186508

Synopsis

The version of Apple iOS running on the mobile device is affected by multiple vulnerabilities.

Description

The version of Apple iOS running on the mobile device is prior to 17.1.2. It is, therefore, affected by multiple vulnerabilities.

- An out-of-bounds read was addressed with improved input validation. (CVE-2023-42916)

- A memory corruption vulnerability was addressed with improved locking. (CVE-2023-42917)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version.

Solution

Upgrade to Apple iOS version 17.1.2 or later

See Also

https://support.apple.com/en-us/HT214031

Plugin Details

Severity: High

ID: 186508

File Name: apple_ios_1712_check.nbin

Version: 1.10

Type: local

Published: 12/1/2023

Updated: 5/20/2024

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-42917

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:apple:iphone_os

Required KB Items: mdm/dependency/unlocked

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/30/2023

Vulnerability Publication Date: 11/30/2023

CISA Known Exploited Vulnerability Due Dates: 12/25/2023

Reference Information

CVE: CVE-2023-42916, CVE-2023-42917

APPLE-SA: HT214031

IAVA: 2023-A-0664-S