Mandrake Linux Security Advisory : zlib (MDKSA-2005:112)

High Nessus Plugin ID 18649


The remote Mandrake Linux host is missing one or more security updates.


Tavis Ormandy of the Gentoo Security Project discovered a vulnerability in zlib where a certain data stream would cause zlib to corrupt a data structure, resulting in the linked application to dump core.

The updated packages have been patched to correct this problem.


Update the affected zlib1 and / or zlib1-devel packages.

Plugin Details

Severity: High

ID: 18649

File Name: mandrake_MDKSA-2005-112.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2005/07/08

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:zlib1, p-cpe:/a:mandriva:linux:zlib1-devel, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/07/06

Reference Information

CVE: CVE-2005-2096

MDKSA: 2005:112