Debian DSA-737-1 : clamav - remote denial of service

Medium Nessus Plugin ID 18629

Synopsis

The remote Debian host is missing a security-related update.

Description

A number of potential remote denial of service vulnerabilities have been identified in ClamAV. In addition to the four issues identified by CVE ID above, there are fixes for issues in libclamav/cvd.c and libclamav/message.c. Together, these issues could allow a carefully crafted message to crash a ClamAV scanner or exhaust various resources on the machine running the scanner.

Solution

Upgrade the clamav package.

For the stable distribution (sarge), these problems have been fixed in version 0.84-2.sarge.1.

See Also

http://www.debian.org/security/2005/dsa-737

Plugin Details

Severity: Medium

ID: 18629

File Name: debian_DSA-737.nasl

Version: 1.16

Type: local

Agent: unix

Published: 2005/07/06

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:clamav, cpe:/o:debian:debian_linux:3.1

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2005/07/05

Vulnerability Publication Date: 2005/06/23

Reference Information

CVE: CVE-2005-1922, CVE-2005-1923, CVE-2005-2056, CVE-2005-2070

DSA: 737