RHEL 8 : fence-agents (RHSA-2023:7407)

critical Nessus Plugin ID 186067

Synopsis

The remote Red Hat host is missing one or more security updates for fence-agents.

Description

The remote Redhat Enterprise Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2023:7407 advisory.

- Certifi is a curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. Certifi prior to version 2023.07.22 recognizes e-Tugra root certificates. e-Tugra's root certificates were subject to an investigation prompted by reporting of security issues in their systems. Certifi 2023.07.22 removes root certificates from e-Tugra from the root store. (CVE-2023-37920)

- urllib3 is a user-friendly HTTP client library for Python. urllib3 doesn't treat the `Cookie` HTTP header special or provide any helpers for managing cookies over HTTP, that is the responsibility of the user.
However, it is possible for a user to specify a `Cookie` header and unknowingly leak information via HTTP redirects to a different origin if that user doesn't disable redirects explicitly. This issue has been patched in urllib3 version 1.26.17 or 2.0.5. (CVE-2023-43804)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the RHEL fence-agents package based on the guidance in RHSA-2023:7407.

See Also

https://access.redhat.com/security/cve/CVE-2023-37920

https://access.redhat.com/security/cve/CVE-2023-43804

https://access.redhat.com/errata/RHSA-2023:7407

Plugin Details

Severity: Critical

ID: 186067

File Name: redhat-RHSA-2023-7407.nasl

Version: 1.3

Type: local

Agent: unix

Published: 11/21/2023

Updated: 1/26/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.0

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-37920

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:rhel_aus:8.6, cpe:/o:redhat:rhel_e4s:8.6, cpe:/o:redhat:rhel_eus:8.6, cpe:/o:redhat:rhel_tus:8.6, p-cpe:/a:redhat:enterprise_linux:fence-agents-aliyun, p-cpe:/a:redhat:enterprise_linux:fence-agents-all, p-cpe:/a:redhat:enterprise_linux:fence-agents-amt-ws, p-cpe:/a:redhat:enterprise_linux:fence-agents-apc, p-cpe:/a:redhat:enterprise_linux:fence-agents-apc-snmp, p-cpe:/a:redhat:enterprise_linux:fence-agents-aws, p-cpe:/a:redhat:enterprise_linux:fence-agents-azure-arm, p-cpe:/a:redhat:enterprise_linux:fence-agents-bladecenter, p-cpe:/a:redhat:enterprise_linux:fence-agents-brocade, p-cpe:/a:redhat:enterprise_linux:fence-agents-cisco-mds, p-cpe:/a:redhat:enterprise_linux:fence-agents-cisco-ucs, p-cpe:/a:redhat:enterprise_linux:fence-agents-common, p-cpe:/a:redhat:enterprise_linux:fence-agents-compute, p-cpe:/a:redhat:enterprise_linux:fence-agents-drac5, p-cpe:/a:redhat:enterprise_linux:fence-agents-eaton-snmp, p-cpe:/a:redhat:enterprise_linux:fence-agents-emerson, p-cpe:/a:redhat:enterprise_linux:fence-agents-eps, p-cpe:/a:redhat:enterprise_linux:fence-agents-gce, p-cpe:/a:redhat:enterprise_linux:fence-agents-heuristics-ping, p-cpe:/a:redhat:enterprise_linux:fence-agents-hpblade, p-cpe:/a:redhat:enterprise_linux:fence-agents-ibm-powervs, p-cpe:/a:redhat:enterprise_linux:fence-agents-ibm-vpc, p-cpe:/a:redhat:enterprise_linux:fence-agents-ibmblade, p-cpe:/a:redhat:enterprise_linux:fence-agents-ifmib, p-cpe:/a:redhat:enterprise_linux:fence-agents-ilo-moonshot, p-cpe:/a:redhat:enterprise_linux:fence-agents-ilo-mp, p-cpe:/a:redhat:enterprise_linux:fence-agents-ilo-ssh, p-cpe:/a:redhat:enterprise_linux:fence-agents-ilo2, p-cpe:/a:redhat:enterprise_linux:fence-agents-intelmodular, p-cpe:/a:redhat:enterprise_linux:fence-agents-ipdu, p-cpe:/a:redhat:enterprise_linux:fence-agents-ipmilan, p-cpe:/a:redhat:enterprise_linux:fence-agents-kdump, p-cpe:/a:redhat:enterprise_linux:fence-agents-kubevirt, p-cpe:/a:redhat:enterprise_linux:fence-agents-lpar, p-cpe:/a:redhat:enterprise_linux:fence-agents-mpath, p-cpe:/a:redhat:enterprise_linux:fence-agents-redfish, p-cpe:/a:redhat:enterprise_linux:fence-agents-rhevm, p-cpe:/a:redhat:enterprise_linux:fence-agents-rsa, p-cpe:/a:redhat:enterprise_linux:fence-agents-rsb, p-cpe:/a:redhat:enterprise_linux:fence-agents-sbd, p-cpe:/a:redhat:enterprise_linux:fence-agents-scsi, p-cpe:/a:redhat:enterprise_linux:fence-agents-virsh, p-cpe:/a:redhat:enterprise_linux:fence-agents-vmware-rest, p-cpe:/a:redhat:enterprise_linux:fence-agents-vmware-soap, p-cpe:/a:redhat:enterprise_linux:fence-agents-wti, p-cpe:/a:redhat:enterprise_linux:fence-agents-zvm

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 11/21/2023

Vulnerability Publication Date: 7/25/2023

Reference Information

CVE: CVE-2023-37920, CVE-2023-43804

CWE: 200, 345

RHSA: 2023:7407