Inframail FTP Server NLST Command Remote Overflow

High Nessus Plugin ID 18587


The remote FTP server is vulnerable to a buffer overflow attack.


The remote host is running the FTP server component of Inframail, a commercial suite of network servers from Infradig Systems.

According to its banner, the installed version of Inframail suffers from a buffer overflow vulnerability that arises when the FTP server component processes an NLST command with an excessively long argument (around 102400 bytes). Successful exploitation will cause the service to crash and may allow arbitrary code execution.


Upgrade to Inframail 7.12 or later.

See Also

Plugin Details

Severity: High

ID: 18587

File Name: inframail_as_ftp_overflow.nasl

Version: $Revision: 1.14 $

Type: remote

Family: FTP

Published: 2005/06/29

Modified: 2016/10/27

Dependencies: 10084, 10092

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7.6

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

Vulnerability Information

Excluded KB Items: ftp/msftpd, ftp/ncftpd, ftp/fw1ftpd, ftp/vxftpd

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2005/06/27

Reference Information

CVE: CVE-2005-2085

BID: 14077

OSVDB: 17608