Mandrake Linux Security Advisory : ImageMagick (MDKSA-2005:107)

Medium Nessus Plugin ID 18584


The remote Mandrake Linux host is missing one or more security updates.


A heap-based buffer overflow was found in the way that ImageMagick parses PNM files. If an attacker can trick a victim into opening a specially crafted PNM file, the attacker could execute arbitrary code on the victim's machine (CVE-2005-1275).

As well, a Denial of Service vulnerability was found in the way that ImageMagick parses XWD files. If a user or program executed ImageMagick to process a malicious XWD file, ImageMagick will enter info an infinite loop causing a DoS (CVE-2005-1739).

The updated packages have been patched to fix these issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 18584

File Name: mandrake_MDKSA-2005-107.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/06/28

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ImageMagick, p-cpe:/a:mandriva:linux:ImageMagick-doc, p-cpe:/a:mandriva:linux:lib64Magick6.4.0, p-cpe:/a:mandriva:linux:lib64Magick6.4.0-devel, p-cpe:/a:mandriva:linux:lib64Magick8.0.2, p-cpe:/a:mandriva:linux:lib64Magick8.0.2-devel, p-cpe:/a:mandriva:linux:libMagick6.4.0, p-cpe:/a:mandriva:linux:libMagick6.4.0-devel, p-cpe:/a:mandriva:linux:libMagick8.0.2, p-cpe:/a:mandriva:linux:libMagick8.0.2-devel, p-cpe:/a:mandriva:linux:perl-Image-Magick, p-cpe:/a:mandriva:linux:perl-Magick, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/06/28

Reference Information

CVE: CVE-2005-1275, CVE-2005-1739

MDKSA: 2005:107