GLSA-200506-18 : Tor: Information disclosure

Medium Nessus Plugin ID 18544


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200506-18 (Tor: Information disclosure)

A bug in Tor allows attackers to view arbitrary memory contents from an exit server's process space.
Impact :

A remote attacker could exploit the memory disclosure to gain sensitive information and possibly even private keys.
Workaround :

There is no known workaround at this time.


All Tor users should upgrade to the latest available version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/tor-'

See Also

Plugin Details

Severity: Medium

ID: 18544

File Name: gentoo_GLSA-200506-18.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/06/22

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:tor, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/06/21

Vulnerability Publication Date: 2005/06/10

Reference Information

CVE: CVE-2005-2050

OSVDB: 17413, 17414

GLSA: 200506-18