Yaws Web Server .yaws Script Null Byte Request Source Code Disclosure

Medium Nessus Plugin ID 18522

Synopsis

The remote web server is affected by an information disclosure flaw.

Description

The remote host is running the Yaws web server.

The remote version of this software is vulnerable to a source code disclosure issue. By requesting a '.yaws' script following by %00, an attacker may force the remote server to disclose the source code of that script.

Since scripts may contain sensitive information such as logins and passwords, an attacker may exploit this flaw to obtain some credentials on the remote host or a better understanding of the security of the '.yaws' scripts.

Solution

Upgrade to YAWS 1.56 or newer.

See Also

http://marc.info/?l=bugtraq&m=111927717726371&w=2

Plugin Details

Severity: Medium

ID: 18522

File Name: yaws_source_disclosure.nasl

Version: $Revision: 1.15 $

Type: remote

Family: Web Servers

Published: 2005/06/17

Modified: 2011/03/13

Dependencies: 67257, 10107, 17975

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2005/06/17

Reference Information

CVE: CVE-2005-2008

BID: 13981

OSVDB: 17375