Quicktime < 7.0.1 Quartz Composer Information Disclosure (Mac OS X)

Medium Nessus Plugin ID 18521


The remote host has an application that is affected by an information disclosure vulnerability.


The remote Mac OS X host is running a version of Quicktime 7 which is older than Quicktime 7.0.1. The remote version of this software is vulnerable to an information disclosure flaw when handling Quartz Composer files which may leak data to an arbitrary web location.

To exploit this flaw, an attacker would need to lure a user on the remote host into viewing a specially crafted Quartz Composer object.


Install Quicktime 7.0.1

See Also



Plugin Details

Severity: Medium

ID: 18521

File Name: macosx_Quicktime701.nasl

Version: $Revision: 1.18 $

Type: local

Agent: macosx

Published: 2005/06/17

Modified: 2013/03/04

Dependencies: 15573

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: MacOSX/QuickTime/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/05/31

Vulnerability Publication Date: 2005/05/11

Reference Information

CVE: CVE-2005-1579

BID: 13603

OSVDB: 16376