Opera < 8.01 Multiple Vulnerabilities

Medium Nessus Plugin ID 18503


The remote host has an application that is affected by multiple vulnerabilities.


The version of Opera installed on the remote host is earlier than 8.01 and thus reportedly affected by multiple issues :

- It may be possible for a malicious website to spoof dialog boxes.

- It may be possible for a XMLHttpRequest object to gain unauthorized access to sensitive data.

- The installed version is affected by multiple cross-site scripting vulnerabilities.

- When using the GET form, file path information could be disclosed.


Install Opera 8.01 or later.

See Also


Plugin Details

Severity: Medium

ID: 18503

File Name: opera_multiple_flaws3.nasl

Version: $Revision: 1.17 $

Type: local

Agent: windows

Family: Windows

Published: 2005/06/16

Modified: 2014/04/25

Dependencies: 21746

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2003/02/26

Reference Information

CVE: CVE-2003-1420, CVE-2005-1475

BID: 6962, 12723, 13970, 13969, 14009

OSVDB: 17580, 17741

Secunia: 13253, 15008, 15411, 15423, 15488

CWE: 79