Mandrake Linux Security Advisory : gedit (MDKSA-2005:102)

Low Nessus Plugin ID 18499


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability was discovered in gEdit where it was possible for an attacker to create a file with a carefully crafted name which, when opened, executed arbitrary code on the victim's computer. It is highly unlikely that a user would open such a file, due to the file name, but could possibly be tricked into opening it.

The updated packages have been patched to correct this problem.


Update the affected gedit and / or gedit-devel packages.

Plugin Details

Severity: Low

ID: 18499

File Name: mandrake_MDKSA-2005-102.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/06/16

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gedit, p-cpe:/a:mandriva:linux:gedit-devel, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/06/15

Reference Information

CVE: CVE-2005-1686

MDKSA: 2005:102