GLSA-200506-06 : libextractor: Multiple overflow vulnerabilities

High Nessus Plugin ID 18448


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200506-06 (libextractor: Multiple overflow vulnerabilities)

Xpdf is vulnerable to multiple overflows, as described in GLSA 200501-28. Also, integer overflows were discovered in Real and PNG extractors.
Impact :

An attacker could design malicious PDF, PNG or Real files which, when processed by an application making use of libextractor, would result in the execution of arbitrary code with the rights of the user running the application.
Workaround :

There is no known workaround at this time.


All libextractor users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/libextractor-0.5.0'

See Also

Plugin Details

Severity: High

ID: 18448

File Name: gentoo_GLSA-200506-06.nasl

Version: $Revision: 1.18 $

Type: local

Published: 2005/06/10

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libextractor, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/06/09

Vulnerability Publication Date: 2005/01/18

Reference Information

CVE: CVE-2005-0064

OSVDB: 13050

GLSA: 200506-06