Mandrake Linux Security Advisory : wget (MDKSA-2005:098)

Medium Nessus Plugin ID 18440


The remote Mandrake Linux host is missing a security update.


Two vulnerabilities were found in wget. The first is that an HTTP redirect statement could be used to do a directory traversal and write to files outside of the current directory. The second is that HTTP redirect statements could be used to overwrite dot ('.') files, potentially overwriting the user's configuration files (such as .bashrc, etc.).

The updated packages have been patched to help address these problems by replacing dangerous directories and filenames containing the dot ('.') character with an underscore ('_') character.


Update the affected wget package.

Plugin Details

Severity: Medium

ID: 18440

File Name: mandrake_MDKSA-2005-098.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/06/10

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:wget, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/06/09

Reference Information

CVE: CVE-2004-1487, CVE-2004-1488

MDKSA: 2005:098