MiniShare Webserver HTTP GET Request Remote Overflow

High Nessus Plugin ID 18424


The remote web server is affected by a remote buffer overflow vulnerability.


MiniShare 1.4.1 and prior versions are affected by a buffer overflow flaw. A remote attacker could execute arbitrary commands by sending a specially crafted file name in a the GET request.

Version 1.3.4 and below do not seem to be vulnerable.


Upgrade to MiniShare 1.4.2 or higher.

See Also

Plugin Details

Severity: High

ID: 18424

File Name: minishare_overflow.nasl

Version: $Revision: 1.17 $

Type: remote

Family: Web Servers

Published: 2005/06/06

Modified: 2016/11/28

Dependencies: 10107, 10386, 17975

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2004/11/07

Exploitable With

Core Impact

Metasploit (Minishare 1.4.1 Buffer Overflow)

Reference Information

CVE: CVE-2004-2271

BID: 11620

OSVDB: 11530