Apache ActiveMQ < 5.15.16 / 5.16.x < 5.16.7 / 5.17.x < 5.17.6 / 5.18.x < 5.18.3 RCE

critical Nessus Plugin ID 184189


The remote host is running a web application that is affected by remote code execution vulnerability.


Apache ActiveMQ is vulnerable to remote code execution. The vulnerability may allow a remote attacker with network access to a broker to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause the broker to instantiate any class on the classpath. Users are recommended to upgrade to versions 5.15.16, 5.16.7, 5.17.6 or 5.18.3, which address this issue.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache ActiveMQ version 5.15.16, 5.16.7, 5.17.6, 5.18.3 or later.

See Also



Plugin Details

Severity: Critical

ID: 184189

File Name: activemq_5_18_3.nasl

Version: 1.11

Type: combined

Agent: unix

Family: CGI abuses

Published: 11/2/2023

Updated: 6/6/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: High

Score: 8.4


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-46604


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/Apache ActiveMQ

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/24/2023

Vulnerability Publication Date: 10/24/2023

CISA Known Exploited Vulnerability Due Dates: 11/23/2023

Exploitable With

Core Impact

Metasploit (Apache ActiveMQ Unauthenticated Remote Code Execution)

Reference Information

CVE: CVE-2023-46604

IAVB: 2023-B-0086-S