Mandrake Linux Security Advisory : postgresql (MDKSA-2005:093)

High Nessus Plugin ID 18411


The remote Mandrake Linux host is missing one or more security updates.


A number of vulnerabilities were found and corrected in the PostgreSQL DBMS :

Two serious security errors have been found in PostgreSQL 7.3 and newer releases. These errors at least allow an unprivileged database user to crash the backend process, and may make it possible for an unprivileged user to gain the privileges of a database superuser.

Functions that support client-to-server character set conversion can be called from SQL commands by unprivileged users, but these functions are not designed to be safe against malicious choices of argument values. (CVE-2005-1409)

The contrib/tsearch2 module misdeclares several functions as returning type 'internal' when they do not have any 'internal' argument. This breaks the type safety of 'internal' by allowing users to construct SQL commands that invoke other functions accepting 'internal' arguments. (CVE-2005-1410)

These vulnerabilities must also be fixed in all existing databases when upgrading. The post-installation script of the updated postgresql-server package attempts to do this automatically.

The updated packages have been patched to correct these problems.


Update the affected packages.

Plugin Details

Severity: High

ID: 18411

File Name: mandrake_MDKSA-2005-093.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/06/02

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64ecpg3, p-cpe:/a:mandriva:linux:lib64ecpg3-devel, p-cpe:/a:mandriva:linux:lib64pgtcl2, p-cpe:/a:mandriva:linux:lib64pgtcl2-devel, p-cpe:/a:mandriva:linux:lib64pq3, p-cpe:/a:mandriva:linux:lib64pq3-devel, p-cpe:/a:mandriva:linux:libecpg3, p-cpe:/a:mandriva:linux:libecpg3-devel, p-cpe:/a:mandriva:linux:libpgtcl2, p-cpe:/a:mandriva:linux:libpgtcl2-devel, p-cpe:/a:mandriva:linux:libpq3, p-cpe:/a:mandriva:linux:libpq3-devel, p-cpe:/a:mandriva:linux:postgresql, p-cpe:/a:mandriva:linux:postgresql-contrib, p-cpe:/a:mandriva:linux:postgresql-devel, p-cpe:/a:mandriva:linux:postgresql-docs, p-cpe:/a:mandriva:linux:postgresql-jdbc, p-cpe:/a:mandriva:linux:postgresql-pl, p-cpe:/a:mandriva:linux:postgresql-plperl, p-cpe:/a:mandriva:linux:postgresql-plpgsql, p-cpe:/a:mandriva:linux:postgresql-plpython, p-cpe:/a:mandriva:linux:postgresql-pltcl, p-cpe:/a:mandriva:linux:postgresql-server, p-cpe:/a:mandriva:linux:postgresql-tcl, p-cpe:/a:mandriva:linux:postgresql-test, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/05/26

Reference Information

CVE: CVE-2005-1409, CVE-2005-1410

MDKSA: 2005:093